Какая из данных сумм наибольшая
Перейти к содержимому

Какая из данных сумм наибольшая

  • автор:

Функция НАИБОЛЬШИЙ() в EXCEL

k — позиция (начиная с наибольшей) в массиве или диапазоне ячеек. Если k ? 0 или k больше, чем количество значений в массиве , то функция НАИБОЛЬШИЙ() возвращает значение ошибки #ЧИСЛО!

Если n — количество значений в массиве , то формула =НАИБОЛЬШИЙ(массив;1) вернет наибольшее (максимальное) значение, а =НАИБОЛЬШИЙ(массив;n) — наименьшее (минимальное). Т.е. формула =НАИБОЛЬШИЙ(массив;1) эквивалентна =МАКС(массив) , а =НАИБОЛЬШИЙ(массив;n) эквивалентна =МИН(массив)

Пустые ячейки, логические значения (ЛОЖЬ и ИСТИНА) и текст функцией игнорируются. Это видно из таблицы в файле примера .

Значение ошибки в ячейке приводит к ошибке в формуле. Прежде чем применять функцию НАИБОЛЬШИЙ () — обработайте ошибку, например с помощью функции ЕСЛИОШИБКА() .

Если в массиве нет ни одного числового значения, то функция вернет значение ошибки #ЧИСЛО!, что выгодно ее отличает от функции МАКС() , возвращающую в этом случае 0!

Значение числа в текстовом формате игнорируется функцией НАИБОЛЬШИЙ () (см. столбец Е на рисунке выше). Перед нахождением наибольшего значения можно попытаться преобразовать все значения в числовой формат. Это можно сделать формулой массива = НАИБОЛЬШИЙ(ЕСЛИ(ЕЧИСЛО(E5:E9+0);E5:E9+0;»»);1)

Необходимо помнить особенность функции НАИБОЛЬШИЙ() при работе со списками чисел, среди которых имеются повторы. Например, если имеется исходный массив 6 ;6;7>, то третьим наибольшим (по версии функции НАИБОЛЬШИЙ() ) будет считаться 6, а не 3. Все правильно и логично, но иногда об этом забывают. С человеческой точки зрения третьим наибольшим будет все-таки, наверное, 3 (т.е. повторы не учитываются).

Наибольший с учетом условия

В отличие от функции СУММ() и СЧЁТ() у НАИБОЛЬШИЙ () нет аналога СУММЕСЛИ() и СЧЁТЕСЛИ() , позволяющих выполнять вычисления с учетом условия. Но, с помощью формул массива можно получить формулу для нахождения наибольшего с учетом условия (см. здесь ).

Сумма 3-х наибольших

С помощью нестандартной записи второго аргумента можно расширить возможности функции НАИБОЛЬШИЙ() . Например, найдем сумму 3-х наибольших значений из диапазона A5:A9 = СУММ(НАИБОЛЬШИЙ(A5:A9;))

Второй аргумент введен как константа массива , что позволило найти 3 наибольших значения.

Аналогично можно найти, например, среднее 2-х наибольших: =СРЗНАЧ(НАИБОЛЬШИЙ(A5:A9;))

Удивительно, но 2 последние формулы даже не обязательно вводить как формулы массива .

Другие применения функции

Функция НАИБОЛЬШИЙ() является достаточно часто используемой, т.к. она позволяет упорядочивать числовые массивы. Ее можно, например, использовать для сортировки списков и таблиц .

Функция сумм в Excel и примеры ее использования

Функция СУММ относится к категории: «Математические». Нажмите комбинацию горячих клавиш SHIFT+F3 для вызова мастера функций, и вы быстро ее там найдете.

Использование этой функции существенно расширяет возможности процесса суммирования значений ячеек в программе Excel. На практике ее рассмотрим возможности и настройки при суммировании нескольких диапазонов.

Как в таблице Excel посчитать сумму столбца?

Просуммируем значение ячеек A1, A2 и A3 с помощью функции суммирования. За одно и узнаем, для чего используется функция сумм.

Инструмент сумма.

  1. После ввода чисел перейдите на ячейку A4. На закладке инструментов «Главная» выберите инструмент «Сумма» в разделе «Редактирование» (или нажмите комбинацию горячих клавиш ALT+=).
  2. Диапазон ячеек распознан автоматически. Адреса ссылок уже введенные в параметры (A1:A3). Пользователю остается только нажать Enter.

В результате в ячейке A4 отображается результат вычисления. Саму функцию и ее параметры можно увидеть в строке формул.

Примечание. Вместо использования инструмента «Сумма» на главной панели, можно в ячейку A4 сразу ввести функцию с параметрами вручную. Результат будет одинаковый.

Поправка автоматического распознания диапазонов

При введении функции с помощью кнопки на панели инструментов или при использовании мастера функций (SHIFT+F3). функция СУММ() относится к группе формул «Математические». Автоматически распознанные диапазоны не всегда являются подходящими для пользователя. Их можно при необходимости быстро и легко поправить.

Допустим, нам нужно просуммировать несколько диапазонов ячеек, как показано на рисунке:

Настройка параметров функции.

  1. Перейдите в ячейку D1 и выберите инструмент «Сумма».
  2. Удерживая клавишу CTRL дополнительно выделите мышкой диапазон A2:B2 и ячейку A3.
  3. После выделения диапазонов нажмите Enter и в ячейке D4 сразу отобразиться результат суммирования значений ячеек всех диапазонов.

Результат суммирования значений.

Обратите внимание на синтаксис в параметрах функции при выделении нескольких диапазонов. Они разделены между собой (;).

В параметрах функции СУММ могут содержаться:

  • ссылки на отдельные ячейки;
  • ссылки на диапазоны ячеек как смежные, так и несмежные;
  • целые и дробные числа.

В параметрах функций все аргументы должны быть разделены точкой с запятой.

Для наглядного примера рассмотрим разные варианты суммирования значений ячеек, которые дают один и тот же результат. Для этого заполните ячейки A1, A2 и A3 числами 1, 2 и 3 соответственно. А диапазон ячеек B1:B5 заполните следующими формулами и функциями:

  • =A1+A2+A3+5;
  • =СУММ(A1:A3)+5;
  • =СУММ(A1;A2;A3)+5;
  • =СУММ(A1:A3;5);
  • =СУММ(A1;A2;A3;5).

При любом варианте мы получаем один и тот же результат вычисления – число 11. Последовательно пройдите курсором от B1 и до B5. В каждой ячейке нажмите F2, чтобы увидеть цветную подсветку ссылок для более понятного анализа синтаксиса записи параметров функций.

Визуальный анализ ссылок.

Одновременное суммирование столбцов

В Excel можно одновременно просуммировать несколько смежных и несмежных столбцов.

Заполняете столбцы, так как показано на рисунке:

Столбцы со значениями разного формата.

  1. Выделите диапазон A1:B3 и удерживая клавишу CTRL так же выделите столбец D1:D3.
  2. На панели «Главная» щелкните по инструменту «Сумма» (или нажмите ALT+=).

Результат одновременного суммирования.

Под каждым столбцом автоматически добавилась функция СУММ(). Теперь в ячейках A4; B4 и D4 отображается результат суммирования каждого столбца. Это самый быстрый и удобный метод.

Примечание. Данная функция автоматически подставляет формат ячеек которых она суммирует.

  • Создать таблицу
  • Форматирование
  • Функции Excel
  • Формулы и диапазоны
  • Фильтр и сортировка
  • Диаграммы и графики
  • Сводные таблицы
  • Печать документов
  • Базы данных и XML
  • Возможности Excel
  • Настройки параметры
  • Уроки Excel
  • Макросы VBA
  • Скачать примеры

СУММ (функция СУММ)

Функция СУММ добавляет значения. Вы можете складывать отдельные значения, диапазоны ячеек, ссылки на ячейки или данные всех этих трех видов.

  • =СУММ(A2:A10) Добавляет значения в ячейки A2:10.
  • =СУММ(A2:A10;C2:C10) Добавляет значения в ячейки A2:10, а также ячейки C2:C10.

Ваш браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

СУММ(число1;[число2];…)

Имя аргумента

Первое число для сложения. Это может быть число 4, ссылка на ячейку, например B6, или диапазон ячеек, например B2:B8.

Это второе число для сложения. Можно указать до 255 чисел.

Рекомендации по использованию функции СУММ

Этот раздел содержит некоторые рекомендации по работе с функцией СУММ. Многие из этих рекомендаций можно применить и к другим функциям.

Метод =1+2 или =A+B. Вы можете ввести =1+2+3 или =A1+B1+C2 и получить абсолютно точные результаты, однако этот метод ненадежен по ряду причин.

  1. Опечатки. Допустим, вы пытаетесь ввести много больших значений такого вида:
    • =14598,93+65437,90+78496,23

А теперь попробуйте проверить правильность записей. Гораздо проще поместить эти значения в отдельные ячейки и использовать их в формуле СУММ. Кроме того, значения в ячейках можно отформатировать, чтобы привести их к более наглядному виду, чем если бы они были в формуле.

Используйте функцию СУММ, вместо того чтобы указывать значения прямо в формулах. Ячейка D5 содержит формулу =СУММ(D2:D4)

  • =A1+B1+C1 или =A1+A2+A3

Пример неудачной формулы. Ячейка D2 содержит формулу =A2+B2+C2

Если ячейки, на которые указывают ссылки, содержат нечисловые (текстовые) значения, формула может вернуть ошибку #ЗНАЧ!. Функция СУММ пропускает текстовые значения и выдает сумму только числовых значений.

Правильная формула. Вместо выражения =A2+B2+C2 ячейка D2 содержит формулу =СУММ(A2:C2)

Ошибка #ССЫЛКА! возникла из-за удаления столбца. Формула приняла вид =A2+#ССЫЛКА!+B2

Ошибка #ССЫЛКА! при удалении строк или столбцов

Функция СУММ будет автоматически корректироваться при вставке и удалении строк и столбцов.

При удалении строки или столбца формулы не обновляются: из них не исключаются удаленные значения, поэтому возвращается ошибка #ССЫЛКА!. Функция СУММ, в свою очередь, обновляется автоматически.

Формулы =A+B+C не обновляются при добавлении строк

Формулы не обновляют ссылки при вставке строк или столбцов

В примере показана формула СУММ, которая при добавлении столбца автоматически расширяется от =СУММ(A2:C2) до =СУММ(A2:D2)

При вставке строки или столбца формула не обновляется — в нее не включается добавленная строка, тогда как функция СУММ будет автоматически обновляться (пока вы не вышли за пределы диапазона, на который ссылается формула). Это особенно важно, когда вы рассчитываете, что формула обновится, но этого не происходит. В итоге ваши результаты остаются неполными, и этого можно не заметить.

  • =СУММ(A1;A2;A3;B1;B2;B3)

вы изначально закладываете в нее вероятность появления ошибок при вставке или удалении строк в указанном диапазоне по тем же причинам. Гораздо лучше использовать отдельные диапазоны, например:

Такая формула будет обновляться при добавлении и удалении строк.

Вопросы и ответы

Расчет времени

  1. Мне нужно добавить, вычесть, умножить или поделить числа. Просмотрите серию учебных видео: Основные математические операции в Excel или Использование Microsoft Excel в качестве калькулятора.
  2. Как уменьшить или увеличить число отображаемых десятичных знаков? Можно изменить числовой формат. Выберите соответствующую ячейку или соответствующий диапазон и нажмите клавиши CTRL+1, чтобы открыть диалоговое окно Формат ячеек, затем щелкните вкладку Число и выберите нужный формат, указав при этом нужное количество десятичных знаков.
  3. Как добавить или вычесть значения времени? Есть несколько способов добавить или вычесть значения времени. Например, чтобы получить разницу между 8:00 и 12:00 для вычисления заработной платы, можно воспользоваться формулой =(«12:00»-«8:00»)*24, т. е. отнять время начала от времени окончания. Обратите внимание, что Excel вычисляет значения времени как часть дня, поэтому чтобы получить суммарное количество часов, необходимо умножить результат на 24. В первом примере используется формула =((B2-A2)+(D2-C2))*24 для вычисления количества часов от начала до окончания работы с учетом обеденного перерыва (всего 8,5 часов). Если вам нужно просто добавить часы и минуты, вы можете просто вычислить сумму, не умножая ее на 24. Во втором примере используется формула =СУММ(A6:C6), так как здесь нужно просто посчитать общее количество часов и минут, затраченных на задания (5:36, т. е. 5 часов 36 минут).

Вычисление разницы между датами

Дополнительные сведения см. в статье Сложение и вычитание значений времени
Как получить разницу между датами? Как и значения времени, значения дат можно добавить или вычесть. Вот распространенный пример вычисления количества дней между датами. Для этого используется простая формула =B2-A2. При работе со значениями дат и времени важно помнить, что дата или время начала вычитается из даты или времени окончания.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Как посчитать сумму в Excel: подробная инструкция со скриншотами

Рассказали о пяти способах суммирования значений в электронных таблицах. Показали, как суммировать ячейки по одному или нескольким условиям.

Иллюстрация: Meery Mary для Skillbox Media

Ксеня Шестак

Ксеня Шестак

Рассказывает просто о сложных вещах из мира бизнеса и управления. До редактуры — пять лет в банке и три — в оценке имущества. Разбирается в Excel, финансах и корпоративной жизни.

Суммирование значений ячеек — базовая функция электронных таблиц. Вместо того чтобы вручную складывать числа на калькуляторе, можно суммировать несколько десятков, сотен и тысяч значений всего за несколько секунд.

В Excel есть пять основных способов посчитать сумму: с помощью арифметической формулы, с помощью кнопки «Автосумма» или используя функции СУММ, СУММЕСЛИ, СУММЕСЛИМН. В инструкции покажем на примерах, как использовать все эти способы, а также расскажем, как провести суммирование в «Google Таблицах».

  • Как посчитать сумму с помощью арифметической формулы
  • Как суммировать значения ячеек с помощью кнопки «Автосумма»
  • Как пользоваться функцией СУММ
  • Как посчитать сумму по одному условию
  • Как посчитать сумму по нескольким условиям
  • Как посчитать сумму в «Google Таблицах»
  • Как узнать больше о работе в Excel

Как посчитать сумму в Excel с помощью арифметической формулы

Допустим, нам нужно суммировать два значения таблицы — ячейки А1 и А2.

Выберем пустую ячейку, в которой хотим получить результат суммирования, и нажмём на знак равенства. Дальше кликнем по первой ячейке, которую нужно просуммировать, — А1. Введём оператор сложения + и кликнем по второй ячейке для суммирования — А2.

Одновременно с этим в выбранной ячейке и в строке формул появится формула: =А1+А2. Нажмём клавишу Enter — Excel проведёт расчёт и покажет результат.

Этот способ лучше всего использовать, когда значений для суммирования не очень много — не больше трёх. В остальных случаях лучше подойдут другие способы, о которых мы будем рассказывать ниже. Если пользоваться ими, расчёт будет гораздо быстрее.

Если вы только начинаете разбираться, как работать в электронных таблицах, прочитайте наш материал «Как создавать формулы в Excel: инструкция для новичков». Там мы рассказывали о принципах работы с формулами.

Как посчитать сумму в Excel с помощью кнопки «Автосумма»

Это самый быстрый способ суммировать ячейки одной строки или одного столбца. Разберём на примере, как он работает.

Допустим, нам нужно суммировать цены автомобилей в таблице с продажами автосалона. Выберем пустую ячейку в столбце «Цена, руб.» и нажмём на кнопку «Σ» на главной вкладке Excel. В появившемся меню выберем «Сумма».

Если в вашей версии Excel этой кнопки нет на главной вкладке, перейдите во вкладку «Формулы» и нажмите кнопку там.

В выбранной ячейке появится название формулы для расчёта суммы и ссылка на диапазон, который Excel автоматически определил для суммирования, — все ячейки с ценами авто. При необходимости диапазон можно скорректировать вручную.

В строке формул функция приняла вид: fx=СУММ(E2:E39).

Нажимаем Enter — в выбранной ячейке появляется результат суммирования.

Кнопка «Автосумма» работает не только со столбцами, но и со строками.

Допустим, цены в каталоге расположены горизонтально. Чтобы суммировать их, выберем пустую ячейку в строке «Цены, руб.» и так же выберем в меню «Σ» → «Сумма». Проверим диапазон, значения которого предлагает суммировать Excel, и нажмём Enter. Готово!

Кроме суммирования, с помощью кнопки «Σ» можно рассчитать среднее значение диапазона, подсчитать количество значений в выбранном столбце или строке, а также показать максимальное и минимальное значение в диапазоне.

Обучение в Skillbox для тех, кто хочет стать профессионалом в Excel

  • Курс «Excel + „Google Таблицы“ с нуля до PRO»
  • Курс «Excel для рабочих и личных задач»
  • Бесплатный онлайн-интенсив «Экспресс-курс по Excel: осваиваем таблицы с нуля за 3 дня»
  • Бесплатные видеоуроки по Excel и «Google Таблицам»

Как посчитать сумму в Excel с помощью функции СУММ

СУММ — функция Excel, которая проводит суммирование значений ячеек. Это классический способ для расчёта суммы нескольких значений.

В предыдущем способе кнопка «Автосумма» использовала для расчёта эту же функцию: автоматически прописывала в строке формул имя функции и диапазон аргументов .

В некоторых случаях использовать «Автосумму» неудобно — например, когда в расчёт нужно включить не все ячейки выбранного столбца или строки или суммировать сразу несколько диапазонов. Для этого лучше воспользоваться функцией СУММ вручную. Разберём на примере, как это сделать.

Допустим, нам нужно суммировать цены автомобилей, расположенные на разных листах Excel. Выберем пустую ячейку и нажмём на кнопку «Fx» левее строки формул.

В правой части экрана появится окно «Построитель формул» с перечнем доступных функций. Найдём функцию СУММ и кликнем по ней два раза.

В появившемся окне нужно ввести аргументы функции — диапазоны значений для суммирования. Для этого поставим курсор в строку «Число1» и мышкой выделим первый диапазон — в нашем случае это диапазон с ценами авто с первого листа: Е2:Е20.

Дальше переставим курсор на строку «Число2» и выделим диапазон со второго листа Excel. В построителе формул он отразится в таком виде: ‘Лист0 (2)’!E2:E20.

Если нужно добавить дополнительные аргументы — нажмите «+» под строкой «Число2» построителя формул.

Затем жмём «Готово» — функция проводит расчёт и показывает результат в ячейке, которую мы выбрали в самом начале.

Одновременно с этим функция в строке формул принимает вид: Fx=СУММ(E2:E20;’Лист0 (2)’! E2:E20).

Опытные пользователи Excel редко запускают построитель формул для суммирования — они сразу прописывают функцию в строке формул. Для этого нужно выбрать пустую ячейку, поставить знак равенства — в этой ячейке или сразу в строке формул — и ввести название функции. Затем в скобках через ; нужно перечислить ячейки для суммирования или их диапазоны и нажать Enter.

Как посчитать сумму по одному условию: функция СУММЕСЛИ

СУММЕСЛИ — функция Excel, с помощью которой можно суммировать не все значения выбранного диапазона, а только те, что соответствуют одному заданному пользователем условию. Например, только автомобили 2017 года выпуска. Или только чёрные авто.

Допустим, в нашей таблице продаж автосалона нужно суммировать только данные о продажах менеджера Тригубова М. Вот как это сделать.

Выберем пустую ячейку и вызовем построитель формул, как делали это в предыдущем разделе. В списке функций найдём функцию СУММЕСЛИ — появится окно для ввода аргументов.

Нужно ввести три аргумента функции — диапазон, критерий и диапазон суммирования.

  • Диапазон — ячейки таблицы, в которых Excel будет искать критерий пользователя. В нашем примере нужны данные о продажах менеджера Тригубова, поэтому в качестве диапазона для поиска критерия указываем весь столбец «Менеджер»: G2:G39.
  • Критерий — значение, которое Excel должен найти в выбранном диапазоне. В нашем примере это фамилия и имя менеджера — указываем их в таком же виде, как они указаны в таблице. И обязательно заключаем в кавычки: «Тригубов М.».
  • Диапазон суммирования — диапазон ячеек, которые нужно суммировать. В нашем случае это ячейки столбца «Цена, руб.»: E2:E39.

В результате строка формул принимает такой вид: Fx=СУММЕСЛИ(G2:G39;»Тригубов М.»;E2:E39).

Нажимаем «Готово» — функция просматривает выбранные диапазоны и суммирует значения только тех ячеек с ценами, напротив которых стоит «Тригубов М.». Результат появляется в ячейке, которую мы выбирали в начале.

Как посчитать сумму по нескольким условиям: функция СУММЕСЛИМН

СУММЕСЛИМН — функция Excel, с помощью которой можно суммировать не все значения выбранного диапазона, а только те, что соответствуют нескольким условиям пользователя. То есть эта функция работает аналогично СУММЕСЛИ, но заданных условий может быть больше одного.

Добавим к условию из предыдущего раздела второе условие — год выпуска автомобиля. Суммируем цены авто 2021 года выпуска, которые продал менеджер Тригубов М.

Выберем пустую ячейку, вызовем построитель формул и найдём функцию «СУММЕСЛИМН».

Изначально появится только одна строка для ввода аргументов — «Диапазон_суммирования». Как и в функции СУММЕСЛИ, это диапазон ячеек, значения которых нужно суммировать. В нашем примере это все ячейки столбца «Цена, руб.» — добавим ссылку на этот диапазон в строку аргумента.

Дальше два раза жмём «+» — появятся строки для ввода аргументов первого условия: «Диапазон_условия1» и «Условие1».

Заполняем эти строки первым условием — нужно суммировать цены авто, проданных менеджером Тригубовым М.:

  • Диапазон условия 1 — весь столбец «Менеджер»: G2:G39.
  • Условие 1 — «Тригубов М.».

Дальше нажмём «+» ещё два раза — появятся строки для ввода аргументов второго условия: «Диапазон_условия2» и «Условие2».

В нашем примере второе условие такое: автомобили, цены которых нужно суммировать, должны быть 2021 года выпуска. Заполним аргументы:

  • Диапазон условия 2 — весь столбец «Год выпуска»: C2:C39.
  • Условие 2 — «2021».

Нажимаем «Готово» и получаем результат — функция просмотрела выбранные диапазоны и суммировала только те значения с ценами, напротив которых стоит «Тригубов М.» и «2021».

Как посчитать сумму в «Google Таблицах»? Все описанные выше способы, за исключением кнопки «Автосумма», работают и в «Google Таблицах». Отличие в том, что в «Google Таблицах» нет построителя формул, поэтому синтаксис функций придётся вводить самостоятельно, в строке формул или в пустой ячейке. Когда пользователь начинает писать название функции, под строкой формул появляются подсказки — какие аргументы нужно ввести, чтобы она сработала.

Как узнать больше о работе в Excel

  • В Excel много функций, которые упрощают и ускоряют работу с таблицами. В подборке даём ссылки на 15 статей и видео об инструментах Excel, необходимых в повседневной работе.
  • В Skillbox есть курс «Excel + „Google Таблицы“ с нуля до PRO». Он подойдёт как новичкам, которые хотят научиться работать в Excel с нуля, так и уверенным пользователям, которые хотят улучшить свои навыки. На курсе учат быстро делать сложные расчёты, визуализировать данные, строить прогнозы, работать с внешними источниками данных, создавать макросы и скрипты.
  • Кроме того, Skillbox даёт бесплатный доступ к записи онлайн-интенсива «Экспресс-курс по Excel: осваиваем таблицы с нуля за 3 дня». Он подходит для начинающих пользователей. На нём можно научиться создавать и оформлять листы, вводить данные, использовать формулы и функции для базовых вычислений, настраивать пользовательские форматы и создавать формулы с абсолютными и относительными ссылками.

Изучаете Excel? Посмотрите эти инструкции Skillbox Media

  • Как сделать ВПР в Excel
  • Основы Excel: работаем с выпадающим списком
  • Как сделать сортировку в Excel
  • Как установить фильтр и расширенный фильтр в Excel
  • Логические функции в Excel: для чего нужны и как их использовать

Аргументы — значения, которые функция использует для выполнения расчётов.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *